android studioでエラー「Gradle sync failed: Minimum supported Gradle version is 5.4.1. Current version is 5.1.1. If using the gradle wrapper, try editing the distributionUrl」

<strong><span style=”color: #ff0000;”>Gradle sync failed: Minimum supported Gradle version is 5.4.1. Current version is 5.1.1. If using the gradle wrapper, try editing the distributionUrl</span></strong>

このエラーはanddroid stuioのgradleのバージョンが低すぎる時に出るエラーです。

gradleのバージョンを上げるのは簡単です。

&nbsp;

file &gt; project structure &gt; gradleのバージョン

とありますので、このバージョンを手入力で変えます。

5.1.1

のバージョンなら手入力で

5.4.1

と書き換えます。

後はOKを押せば自動でアップデートしてくれます。<!–more–>

android studioのインストール時にエラー「Your SDK location contains non-ASCII characters」

android studioのインストール時に

「Your SDK location contains non-ASCII characters」

のエラーが出てしまった。

このエラーはSDKフォルダを生成する時に日本語のパスが含まれていると出るエラーです。

フォルダの名前は日本語で入れていたので出たようです。

そんな時はインストール先のフォルダを日本語の含まないパスに変更します。